]> ruderich.org/simon Gitweb - coloredstderr/coloredstderr.git/blobdiff - tests/Makefile.am
Add simple test suite.
[coloredstderr/coloredstderr.git] / tests / Makefile.am
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644 (file)
index 0000000..9928cdc
--- /dev/null
@@ -0,0 +1,15 @@
+TESTS = run.sh
+check_PROGRAMS = example
+example_SOURCES = example.c
+
+dist_check_SCRIPTS = run.sh lib.sh
+dist_check_DATA = example.expected \
+                  example-noforce.sh \
+                  example-noforce.sh.expected \
+                  example-redirects.sh \
+                  example-redirects.sh.expected \
+                  example-simple.sh \
+                  example-simple.sh.expected
+
+# Used by run.sh.
+export EGREP