]> ruderich.org/simon Gitweb - coloredstderr/coloredstderr.git/blobdiff - tests/Makefile.am
tests/Makefile.am: Fix for BSD's make.
[coloredstderr/coloredstderr.git] / tests / Makefile.am
index 9928cdc23de55b61d67f2d0235a76948a34294df..24f94e06294516878ec9bb4db9e1722c1aca5cdd 100644 (file)
@@ -1,15 +1,43 @@
-TESTS = run.sh
-check_PROGRAMS = example
-example_SOURCES = example.c
-
-dist_check_SCRIPTS = run.sh lib.sh
-dist_check_DATA = example.expected \
-                  example-noforce.sh \
-                  example-noforce.sh.expected \
-                  example-redirects.sh \
-                  example-redirects.sh.expected \
-                  example-simple.sh \
-                  example-simple.sh.expected
-
-# Used by run.sh.
-export EGREP
+# Default since automake 1.13, necessary for older versions.
+AUTOMAKE_OPTIONS = color-tests parallel-tests
+
+TESTS = test_environment.sh \
+        test_example.sh \
+        test_exec.sh \
+        test_noforce.sh \
+        test_redirects.sh \
+        test_simple.sh
+check_PROGRAMS = example example_exec
+
+if HAVE_ERR_H
+    TESTS += test_err.sh
+    check_PROGRAMS += example_err
+endif
+if HAVE_ERROR_H
+    TESTS += test_error.sh
+    check_PROGRAMS += example_error
+endif
+if HAVE_VFORK
+    TESTS += test_vfork.sh
+    check_PROGRAMS += example_vfork
+endif
+
+dist_check_SCRIPTS = $(TESTS) lib.sh
+dist_check_DATA = example.h \
+                  example.expected \
+                  example_environment.expected \
+                  example_environment_empty.expected \
+                  example_err.expected \
+                  example_error.expected \
+                  example_exec.expected \
+                  example_noforce.sh \
+                  example_noforce.sh.expected \
+                  example_redirects.sh \
+                  example_redirects.sh.expected \
+                  example_simple.sh \
+                  example_simple.sh.expected \
+                  example_vfork.expected
+
+# Used by lib.sh. Can't use "export EGREP" because it doesn't work with BSD's
+# make.
+AM_MAKEFLAGS = "EGREP=$(EGREP)"