]> ruderich.org/simon Gitweb - coloredstderr/coloredstderr.git/blobdiff - tests/Makefile.am
tests: Rename example-* to example_* for consistency.
[coloredstderr/coloredstderr.git] / tests / Makefile.am
index bfaaea2edaaecff34a4f127359c7037413d23c25..32d9ca35431ac1bff830c4454de8e8addb1a73b2 100644 (file)
@@ -1,17 +1,28 @@
 TESTS = run.sh
-check_PROGRAMS = example example_vfork
+check_PROGRAMS = example example_exec
 example_SOURCES = example.c
-example_vfork_SOURCES = example_vfork.c
+example_exec_SOURCES = example_exec.c
+
+if HAVE_ERROR_H
+    check_PROGRAMS += example_error
+    example_error_SOURCES = example_error.c
+endif
+if HAVE_VFORK
+    check_PROGRAMS += example_vfork
+    example_vfork_SOURCES = example_vfork.c
+endif
 
 dist_check_SCRIPTS = run.sh lib.sh
 dist_check_DATA = example.expected \
+                  example_error.expected \
+                  example_exec.expected \
                   example_vfork.expected \
-                  example-noforce.sh \
-                  example-noforce.sh.expected \
-                  example-redirects.sh \
-                  example-redirects.sh.expected \
-                  example-simple.sh \
-                  example-simple.sh.expected
+                  example_noforce.sh \
+                  example_noforce.sh.expected \
+                  example_redirects.sh \
+                  example_redirects.sh.expected \
+                  example_simple.sh \
+                  example_simple.sh.expected
 
 # Used by run.sh.
 export EGREP