]> ruderich.org/simon Gitweb - coloredstderr/coloredstderr.git/blobdiff - tests/Makefile.am
tests: Split run.sh in multiple test files.
[coloredstderr/coloredstderr.git] / tests / Makefile.am
index 32d9ca35431ac1bff830c4454de8e8addb1a73b2..3ccce2447a739840662e9a9fbe5d84561e411ade 100644 (file)
@@ -1,18 +1,24 @@
-TESTS = run.sh
+TESTS = test_example.sh \
+        test_exec.sh \
+        test_noforce.sh \
+        test_redirects.sh \
+        test_simple.sh
 check_PROGRAMS = example example_exec
 example_SOURCES = example.c
 example_exec_SOURCES = example_exec.c
 
 if HAVE_ERROR_H
+    TESTS += test_error.sh
     check_PROGRAMS += example_error
     example_error_SOURCES = example_error.c
 endif
 if HAVE_VFORK
+    TESTS += test_vfork.sh
     check_PROGRAMS += example_vfork
     example_vfork_SOURCES = example_vfork.c
 endif
 
-dist_check_SCRIPTS = run.sh lib.sh
+dist_check_SCRIPTS = $(TESTS) lib.sh
 dist_check_DATA = example.expected \
                   example_error.expected \
                   example_exec.expected \
@@ -24,5 +30,5 @@ dist_check_DATA = example.expected \
                   example_simple.sh \
                   example_simple.sh.expected
 
-# Used by run.sh.
+# Used by lib.sh.
 export EGREP