]> ruderich.org/simon Gitweb - coloredstderr/coloredstderr.git/blobdiff - tests/Makefile.am
tests: Remove test_symbols.sh.
[coloredstderr/coloredstderr.git] / tests / Makefile.am
index a42be2356ec66ce15a98bd3df860af9850c0ad0d..74ecac9dee9b1cef3fc39c2cd4c3fe489ca7460f 100644 (file)
@@ -1,13 +1,21 @@
-TESTS = test_example.sh \
+# Default since automake 1.13, necessary for older versions.
+AUTOMAKE_OPTIONS = color-tests parallel-tests
+
+TESTS = test_environment.sh \
+        test_example.sh \
         test_exec.sh \
         test_noforce.sh \
         test_redirects.sh \
-        test_simple.sh \
-        test_symbols.sh
+        test_simple.sh
 check_PROGRAMS = example example_exec
 example_SOURCES = example.c
 example_exec_SOURCES = example_exec.c
 
+if HAVE_ERR_H
+    TESTS += test_err.sh
+    check_PROGRAMS += example_err
+    example_error_SOURCES = example_err.c
+endif
 if HAVE_ERROR_H
     TESTS += test_error.sh
     check_PROGRAMS += example_error
@@ -20,7 +28,11 @@ if HAVE_VFORK
 endif
 
 dist_check_SCRIPTS = $(TESTS) lib.sh
-dist_check_DATA = example.expected \
+dist_check_DATA = example.h \
+                  example.expected \
+                  example_environment.expected \
+                  example_environment_empty.expected \
+                  example_err.expected \
                   example_error.expected \
                   example_exec.expected \
                   example_noforce.sh \