]> ruderich.org/simon Gitweb - coloredstderr/coloredstderr.git/blobdiff - tests/Makefile.am
tests: Remove test_symbols.sh.
[coloredstderr/coloredstderr.git] / tests / Makefile.am
index bfaaea2edaaecff34a4f127359c7037413d23c25..74ecac9dee9b1cef3fc39c2cd4c3fe489ca7460f 100644 (file)
@@ -1,17 +1,47 @@
-TESTS = run.sh
-check_PROGRAMS = example example_vfork
+# Default since automake 1.13, necessary for older versions.
+AUTOMAKE_OPTIONS = color-tests parallel-tests
+
+TESTS = test_environment.sh \
+        test_example.sh \
+        test_exec.sh \
+        test_noforce.sh \
+        test_redirects.sh \
+        test_simple.sh
+check_PROGRAMS = example example_exec
 example_SOURCES = example.c
-example_vfork_SOURCES = example_vfork.c
+example_exec_SOURCES = example_exec.c
+
+if HAVE_ERR_H
+    TESTS += test_err.sh
+    check_PROGRAMS += example_err
+    example_error_SOURCES = example_err.c
+endif
+if HAVE_ERROR_H
+    TESTS += test_error.sh
+    check_PROGRAMS += example_error
+    example_error_SOURCES = example_error.c
+endif
+if HAVE_VFORK
+    TESTS += test_vfork.sh
+    check_PROGRAMS += example_vfork
+    example_vfork_SOURCES = example_vfork.c
+endif
 
-dist_check_SCRIPTS = run.sh lib.sh
-dist_check_DATA = example.expected \
-                  example_vfork.expected \
-                  example-noforce.sh \
-                  example-noforce.sh.expected \
-                  example-redirects.sh \
-                  example-redirects.sh.expected \
-                  example-simple.sh \
-                  example-simple.sh.expected
+dist_check_SCRIPTS = $(TESTS) lib.sh
+dist_check_DATA = example.h \
+                  example.expected \
+                  example_environment.expected \
+                  example_environment_empty.expected \
+                  example_err.expected \
+                  example_error.expected \
+                  example_exec.expected \
+                  example_noforce.sh \
+                  example_noforce.sh.expected \
+                  example_redirects.sh \
+                  example_redirects.sh.expected \
+                  example_simple.sh \
+                  example_simple.sh.expected \
+                  example_vfork.expected
 
-# Used by run.sh.
+# Used by lib.sh.
 export EGREP