]> ruderich.org/simon Gitweb - coloredstderr/coloredstderr.git/blobdiff - tests/Makefile.am
tests/test_symbols.sh: Add.
[coloredstderr/coloredstderr.git] / tests / Makefile.am
index bc3a9a93ae634714cf8850f9043fc9bb982eb2b5..a42be2356ec66ce15a98bd3df860af9850c0ad0d 100644 (file)
@@ -1,25 +1,35 @@
-TESTS = run.sh
-check_PROGRAMS = example example_exec example_vfork
+TESTS = test_example.sh \
+        test_exec.sh \
+        test_noforce.sh \
+        test_redirects.sh \
+        test_simple.sh \
+        test_symbols.sh
+check_PROGRAMS = example example_exec
 example_SOURCES = example.c
 example_exec_SOURCES = example_exec.c
-example_vfork_SOURCES = example_vfork.c
 
 if HAVE_ERROR_H
+    TESTS += test_error.sh
     check_PROGRAMS += example_error
     example_error_SOURCES = example_error.c
 endif
+if HAVE_VFORK
+    TESTS += test_vfork.sh
+    check_PROGRAMS += example_vfork
+    example_vfork_SOURCES = example_vfork.c
+endif
 
-dist_check_SCRIPTS = run.sh lib.sh
+dist_check_SCRIPTS = $(TESTS) lib.sh
 dist_check_DATA = example.expected \
                   example_error.expected \
                   example_exec.expected \
-                  example_vfork.expected \
-                  example-noforce.sh \
-                  example-noforce.sh.expected \
-                  example-redirects.sh \
-                  example-redirects.sh.expected \
-                  example-simple.sh \
-                  example-simple.sh.expected
+                  example_noforce.sh \
+                  example_noforce.sh.expected \
+                  example_redirects.sh \
+                  example_redirects.sh.expected \
+                  example_simple.sh \
+                  example_simple.sh.expected \
+                  example_vfork.expected
 
-# Used by run.sh.
+# Used by lib.sh.
 export EGREP