]> ruderich.org/simon Gitweb - coloredstderr/coloredstderr.git/blobdiff - tests/Makefile.am
Fix a few strict compiler warnings.
[coloredstderr/coloredstderr.git] / tests / Makefile.am
index 9928cdc23de55b61d67f2d0235a76948a34294df..bc3a9a93ae634714cf8850f9043fc9bb982eb2b5 100644 (file)
@@ -1,9 +1,19 @@
 TESTS = run.sh
-check_PROGRAMS = example
+check_PROGRAMS = example example_exec example_vfork
 example_SOURCES = example.c
+example_exec_SOURCES = example_exec.c
+example_vfork_SOURCES = example_vfork.c
+
+if HAVE_ERROR_H
+    check_PROGRAMS += example_error
+    example_error_SOURCES = example_error.c
+endif
 
 dist_check_SCRIPTS = run.sh lib.sh
 dist_check_DATA = example.expected \
+                  example_error.expected \
+                  example_exec.expected \
+                  example_vfork.expected \
                   example-noforce.sh \
                   example-noforce.sh.expected \
                   example-redirects.sh \