]> ruderich.org/simon Gitweb - coloredstderr/coloredstderr.git/blobdiff - tests/Makefile.am
Hook error() and error_at_line() if available.
[coloredstderr/coloredstderr.git] / tests / Makefile.am
index bfaaea2edaaecff34a4f127359c7037413d23c25..bc3a9a93ae634714cf8850f9043fc9bb982eb2b5 100644 (file)
@@ -1,10 +1,18 @@
 TESTS = run.sh
-check_PROGRAMS = example example_vfork
+check_PROGRAMS = example example_exec example_vfork
 example_SOURCES = example.c
+example_exec_SOURCES = example_exec.c
 example_vfork_SOURCES = example_vfork.c
 
+if HAVE_ERROR_H
+    check_PROGRAMS += example_error
+    example_error_SOURCES = example_error.c
+endif
+
 dist_check_SCRIPTS = run.sh lib.sh
 dist_check_DATA = example.expected \
+                  example_error.expected \
+                  example_exec.expected \
                   example_vfork.expected \
                   example-noforce.sh \
                   example-noforce.sh.expected \