]> ruderich.org/simon Gitweb - coloredstderr/coloredstderr.git/blobdiff - tests/Makefile.am
tests/Makefile.am: Remove unnecessary *_SOURCES variables.
[coloredstderr/coloredstderr.git] / tests / Makefile.am
index a42be2356ec66ce15a98bd3df860af9850c0ad0d..bf48191e7ba052aa045b998dd3656cb81fb0696a 100644 (file)
@@ -1,26 +1,33 @@
-TESTS = test_example.sh \
+# Default since automake 1.13, necessary for older versions.
+AUTOMAKE_OPTIONS = color-tests parallel-tests
+
+TESTS = test_environment.sh \
+        test_example.sh \
         test_exec.sh \
         test_noforce.sh \
         test_redirects.sh \
-        test_simple.sh \
-        test_symbols.sh
+        test_simple.sh
 check_PROGRAMS = example example_exec
-example_SOURCES = example.c
-example_exec_SOURCES = example_exec.c
 
+if HAVE_ERR_H
+    TESTS += test_err.sh
+    check_PROGRAMS += example_err
+endif
 if HAVE_ERROR_H
     TESTS += test_error.sh
     check_PROGRAMS += example_error
-    example_error_SOURCES = example_error.c
 endif
 if HAVE_VFORK
     TESTS += test_vfork.sh
     check_PROGRAMS += example_vfork
-    example_vfork_SOURCES = example_vfork.c
 endif
 
 dist_check_SCRIPTS = $(TESTS) lib.sh
-dist_check_DATA = example.expected \
+dist_check_DATA = example.h \
+                  example.expected \
+                  example_environment.expected \
+                  example_environment_empty.expected \
+                  example_err.expected \
                   example_error.expected \
                   example_exec.expected \
                   example_noforce.sh \