]> ruderich.org/simon Gitweb - coloredstderr/coloredstderr.git/blobdiff - tests/Makefile.am
m4/ax_c___attribute__.m4: Add.
[coloredstderr/coloredstderr.git] / tests / Makefile.am
index 9928cdc23de55b61d67f2d0235a76948a34294df..f8b0f94b0d17ba254a750d68d95d10add5d34261 100644 (file)
@@ -1,9 +1,22 @@
 TESTS = run.sh
-check_PROGRAMS = example
+check_PROGRAMS = example example_exec
 example_SOURCES = example.c
+example_exec_SOURCES = example_exec.c
+
+if HAVE_ERROR_H
+    check_PROGRAMS += example_error
+    example_error_SOURCES = example_error.c
+endif
+if HAVE_VFORK
+    check_PROGRAMS += example_vfork
+    example_vfork_SOURCES = example_vfork.c
+endif
 
 dist_check_SCRIPTS = run.sh lib.sh
 dist_check_DATA = example.expected \
+                  example_error.expected \
+                  example_exec.expected \
+                  example_vfork.expected \
                   example-noforce.sh \
                   example-noforce.sh.expected \
                   example-redirects.sh \