]> ruderich.org/simon Gitweb - coloredstderr/coloredstderr.git/blobdiff - tests/Makefile.am
tests/Makefile.am: Enable parallel and colored test runs.
[coloredstderr/coloredstderr.git] / tests / Makefile.am
index a42be2356ec66ce15a98bd3df860af9850c0ad0d..80d0cdd445a03b45a54f58a79a600f2112432e3f 100644 (file)
@@ -1,4 +1,8 @@
-TESTS = test_example.sh \
+# Default since automake 1.13, necessary for older versions.
+AUTOMAKE_OPTIONS = color-tests parallel-tests
+
+TESTS = test_environment.sh \
+        test_example.sh \
         test_exec.sh \
         test_noforce.sh \
         test_redirects.sh \
@@ -21,6 +25,8 @@ endif
 
 dist_check_SCRIPTS = $(TESTS) lib.sh
 dist_check_DATA = example.expected \
+                  example_environment.expected \
+                  example_environment_empty.expected \
                   example_error.expected \
                   example_exec.expected \
                   example_noforce.sh \