]> ruderich.org/simon Gitweb - coloredstderr/coloredstderr.git/blobdiff - tests/Makefile.am
tests/Makefile.am: Enable parallel and colored test runs.
[coloredstderr/coloredstderr.git] / tests / Makefile.am
index fa33764e54ec1400bb1c4e7837bfc887d598939e..80d0cdd445a03b45a54f58a79a600f2112432e3f 100644 (file)
@@ -1,8 +1,13 @@
-TESTS = test_example.sh \
+# Default since automake 1.13, necessary for older versions.
+AUTOMAKE_OPTIONS = color-tests parallel-tests
+
+TESTS = test_environment.sh \
+        test_example.sh \
         test_exec.sh \
         test_noforce.sh \
         test_redirects.sh \
-        test_simple.sh
+        test_simple.sh \
+        test_symbols.sh
 check_PROGRAMS = example example_exec
 example_SOURCES = example.c
 example_exec_SOURCES = example_exec.c
@@ -20,6 +25,8 @@ endif
 
 dist_check_SCRIPTS = $(TESTS) lib.sh
 dist_check_DATA = example.expected \
+                  example_environment.expected \
+                  example_environment_empty.expected \
                   example_error.expected \
                   example_exec.expected \
                   example_noforce.sh \