]> ruderich.org/simon Gitweb - tlsproxy/tlsproxy.git/blobdiff - tests/Makefile.am
tests/Makefile.am: Enable parallel and colored test runs.
[tlsproxy/tlsproxy.git] / tests / Makefile.am
index 27ecaff8de411a827b7d1e7a195839746ba3ef9a..b231cccd4098de11e372c7e782632230e89d0b44 100644 (file)
@@ -1,8 +1,19 @@
+# Default since automake 1.13, necessary for older versions.
+AUTOMAKE_OPTIONS = color-tests parallel-tests
+
 TESTS = tests-normal.sh tests-passthrough.sh tests-authentication.sh
 dist_check_SCRIPTS = $(TESTS) common.sh
 check_PROGRAMS = client
-client_SOURCES = client.c
 
 dist_check_DATA = server-bad.pem server-key.pem server.pem
 
-CLEANFILES = proxy-ca-key.pem proxy-ca.pem proxy-key.pem tmp
+CLEANFILES = \
+       proxy-ca-key.pem \
+       proxy-ca.pem \
+       proxy-dh.pem \
+       proxy-invalid.pem \
+       proxy-key.pem \
+       tmp
+
+# Tests can't be run in parallel.
+.NOTPARALLEL: