]> ruderich.org/simon Gitweb - tlsproxy/tlsproxy.git/blobdiff - tests/Makefile.am
tests/Makefile.am: Enable parallel and colored test runs.
[tlsproxy/tlsproxy.git] / tests / Makefile.am
index e727055b7d3b2d1e29499a7c845b9b0063e1819d..b231cccd4098de11e372c7e782632230e89d0b44 100644 (file)
@@ -1,3 +1,6 @@
+# Default since automake 1.13, necessary for older versions.
+AUTOMAKE_OPTIONS = color-tests parallel-tests
+
 TESTS = tests-normal.sh tests-passthrough.sh tests-authentication.sh
 dist_check_SCRIPTS = $(TESTS) common.sh
 check_PROGRAMS = client
@@ -11,3 +14,6 @@ CLEANFILES = \
        proxy-invalid.pem \
        proxy-key.pem \
        tmp
+
+# Tests can't be run in parallel.
+.NOTPARALLEL: